Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Mar 13, 2025 - 10:10 CDT
Update
Some customers are experiencing service interruptions. Property management has been notified of a power-related issues affecting Zentro networking equipment. We are coordinating with building personnel to restore power to our systems. Estimated time of resolution is 3/13/2025 6:30 AM
Posted Mar 12, 2025 - 21:20 CDT
Update
Some customers are experiencing service interruptions. Property management has been notified of a power-related issues affecting Zentro networking equipment. We are coordinating with building personnel to restore power to our systems.
Posted Mar 12, 2025 - 20:41 CDT
Identified
Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 9:30 PM CST
Posted Mar 12, 2025 - 20:05 CDT
Investigating
We are investigating reports of service interruptions at the location.
Posted Mar 12, 2025 - 18:33 CDT
This incident affected: Zentro Network (Zentro Internet).