Las Vegas, NV - 4471 Dean Martin Dr | 6350 S Durango Dr | 2320 S Potosi St | 5712 Aspen Falls Cir | 9101 Alta Dr | 115 E Tropicana Ave | 3863 S Valley View Blvd | 2950 S Rancho Rd | 3940 S Las Vegas Blvd

Incident Report for Zentro

Resolved

Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Jan 03, 2026 - 06:50 CST

Investigating

We are currently investigating this issue.
Posted Jan 02, 2026 - 14:35 CST