3116 West Logan Boulevard, Chicago, IL

Incident Report for Zentro

Resolved

We are currently experiencing service disruptions due to issues with building power affecting our equipment. Building staff have been notified and are actively working to resolve the issue internally.
Services will resume once power is restored and systems are stabilized. For ongoing updates, please contact property staff directly.
Thank you for your patience.
Posted Oct 02, 2025 - 17:10 CDT

Investigating

We are investigating reports of service interruptions at the location.
Posted Oct 02, 2025 - 12:49 CDT
This incident affected: Zentro Network (Zentro Internet).