Chicago, IL - 325 W. Fullerton Pkwy.

Incident Report for Zentro

Resolved

This incident has been resolved.
Posted Jun 22, 2025 - 16:45 CDT

Identified

We have been notified of a power outage in your area. Local Power Utility has an estimated time for resolution by 11:45 PM CDT.
Posted Jun 22, 2025 - 15:32 CDT

Investigating

We are investigating reports of service interruptions at the location.
Posted Jun 22, 2025 - 12:58 CDT
This incident affected: Zentro Network (Zentro Internet).