Detroit, MI

Incident Report for Zentro

Resolved

Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Apr 18, 2025 - 10:04 CDT

Monitoring

Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Apr 18, 2025 - 02:02 CDT

Identified

Maintenance is currently in progress, estimated time for resolution is 5 AM.
Posted Apr 18, 2025 - 00:38 CDT

Investigating

We are investigating reports of service interruptions in this area.
Posted Apr 18, 2025 - 00:22 CDT
This incident affected: Zentro Network (Zentro Internet).