Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Jan 15, 2026 - 11:30 CST
Update
Customers may be experiencing intermittent connectivity. Our team is coordinating with building personnel to resolve and restore services. Our estimated time of repair is 12:00 PM CST on 1/15/2026. We appreciate your patience and understanding in the matter. To stay informed with the latest news please click 'Subscribe'.
Posted Jan 14, 2026 - 19:04 CST
Identified
Customers may be experiencing intermittent connectivity. Our team is working diligently to isolate and resolve the issue. Our next status update will be provided by 4:00 PM CST. To stay informed with the latest updates please click 'Subscribe'.
Posted Jan 14, 2026 - 12:55 CST
Investigating
We are investigating reports of service interruptions at the location.
Posted Jan 14, 2026 - 10:26 CST
This incident affected: Zentro Network (Zentro Internet).