3010 North Shadyvale Street - Orange, CA

Incident Report for Zentro

Monitoring

A fix for service issues has been implemented. Our Team is currently monitoring the connection.
Posted Nov 28, 2025 - 23:39 CST

Investigating

We are continuing to investigate reports of service interruptions at the location. We apologize for the inconvenience.
Posted Nov 28, 2025 - 16:32 CST
This incident affects: Zentro Network (Zentro Internet).