7215 District Ave. Lincolnwood, IL

Incident Report for Zentro

Update

We are continuing to investigate the issue and its suspected causes. We appreciate your patience and apologize for the inconvenience.
Posted Nov 28, 2025 - 16:52 CST

Investigating

We are investigating reports of service interruptions at the location.
Posted Nov 26, 2025 - 17:40 CST
This incident affects: Zentro Network (Zentro Internet).