14126 Marquesas Way, Marina Del Rey, CA

Incident Report for Zentro

Update

Customers in building one may continue to experience service interruptions. Our technicians are working diligently to isolate and resolve the issue. Our next status update will be at 12:00 PM PST. We apologize for the inconvenience and appreciate your patience and understanding in the matter. To stay informed with the latest updates, please click 'Subscribe'.
Posted Nov 27, 2025 - 07:43 CST

Update

Customers may continue to experience service interruptions. Our technicians are working diligently to isolate and resolve the issue. Our next status update will be provided by 5:00 PM PST.
Posted Nov 26, 2025 - 16:11 CST

Identified

Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 2:00 PM local.
Posted Nov 26, 2025 - 11:42 CST

Investigating

We are investigating reports of service interruptions at the location.
Posted Nov 25, 2025 - 17:53 CST
This incident affects: Zentro Network (Zentro Internet).