Virigina Area

Incident Report for Zentro

Resolved

Service has been restored. Our Team is monitoring the connection. If you are still experiencing trouble connecting to the Internet, please open a ticket at myportal.zentrointernet.com or through our website at https://zentrointernet.com/support.
Posted Jun 04, 2025 - 05:11 CDT

Update

Customers may be experiencing intermittent connectivity. Technicians have been dispatched to address the issue. Estimated time to resolution is 5:00 AM EST
Posted Jun 03, 2025 - 23:38 CDT

Update

We are continuing to work on a fix for this issue. We have technians onsite working to restore connectivity.
Posted Jun 03, 2025 - 18:31 CDT

Update

We are currently working to restore services. We currently do not have an estimated time for repair.
Posted Jun 03, 2025 - 13:54 CDT

Identified

We have identified an issue impacting your service. Our team is moving quickly to resolve the issue. Estimated Time to Repair is not determined.
Posted Jun 03, 2025 - 12:21 CDT

Investigating

Virginia Area Customers may be experiencing connectivity issues. Our team is currently investigating.
Posted Jun 03, 2025 - 11:52 CDT
This incident affected: Zentro Network (Zentro Internet).